Yaf教程1:安装

2.9k 记录 一条评论

Yaf 要求 PHP 必须为 5.2 及以上版本,如果是 PHP7,请使用 Yaf 3。本教程使用64位的PHP 5.6,所以使用最后稳定版本 Yaf 2.3.5 为例。

1 Linux服务器

确保服务器上安装了PHP,再到 PHP PECL下载 Yaf 源码:https://pecl.php.net/package/yaf

yaf-source-linux

下载之后解压,使用下面的命令安装Yaf:

$ cd /path/to/yaf-src/
$ phpize
$ ./configure
$ make
$ sudo make install

完成之后,在源码 modules/ 目录下会生成 yaf.so,执行 make install 命令后该文件会被拷贝到系统的 lib 目录。

2 Windows服务器

Windows系统安装相对简单,还是一样的地址::https://pecl.php.net/package/yaf,点击其中DLL图标。

yaf-dll-win

然后会进入DLL下载页面,因为我使用的是phpStudy的64位环境,所以选择如下红框的 X64 DLL包。

yaf-dll-download

说明:如果你的系统是 64 位的,但是PHP不是 64位的,那么应该下载 X86 DLL 包。

下载之后,将DLL包中的 php_yaf.dll 文件解压到 PHP 的 ext 目录下,修改 php.ini, 加入如下一行:

extension=php_yaf.dll

效果如下:

yaf-add-dll

3 查看效果

在网站根目录下创建一个 index.php 文件,内容:

<?php

phpinfo()

浏览器中访问 localhost,就可以看到效果了,正确安装后显示如下:

yaf-success

至此安装完成。

 

1条评论

3
3maio says: 回复

请问博主,是如何编辑出类似:

1 Linux服务器
2 Windows服务器
3 查看效果

这些效果的文章的。是使用了什么插件吗

发表评论

您的电子邮箱地址不会被公开。 必填项已用*标注

昵称 *